NGINX 1.23.0 mainline собранный с Brotli, TLS 1.3, OpenSSL 1.1.1p, поддержкой http2 для Red Hat Enterprise Linux, CentOS, Rocky, Oracle, Alma Linux EL7/EL8/EL9

В репозиторий добавлен NGINX 1.23.0 mainline с поддержкой сжатия brotli от Google, http2, ngx cache purge и ngx http geoip2 module. OpenSSL собран динамически с OpenSSL+QUIC 1.1.1p.

TLS 1.3 final на сегодня работает в Google Chrome 70+ и Mozilla Firefox 63+.

RHEL 8 / Alma Linux 8 / Rocky Linux 8 / CentOS 8 / Other EL8 репозиторий стал модульным. Для установки надо включить соответствующий стрим:

dnf module enable -y nginx:codeit-mainline

Для включения TLS 1.3 надо указать:

ssl_protocols TLSv1.2 TLSv1.3;

C версии 1.21.6 мы собираем OpenSSL+QUIC 1.1.1 отдельно, он устанавливается в /lib64 отдельно с суффиксом .so.81.1.1 и никак не затрагивает системные библиотеки.

NGINX 1.23.0 mainline собранный с Brotli, TLS 1.3, OpenSSL 1.1.1p, поддержкой http2 для Red Hat Enterprise Linux, CentOS, Rocky, Oracle, Alma Linux EL7/EL8/EL9: 3 комментария

  1. Hi,

    when i run command yum update, this error appear:

    Resolving Dependencies
    —> Running transaction check
    —> Package gd-last.x86_64 0:2.3.3-2.el7.remi will be obsoleted
    —> Package gd3php.x86_64 0:2.3.3-4.el7.remi will be updated
    —> Package gd3php.x86_64 0:2.3.3-7.el7.remi will be obsoleting
    —> Package nginx.x86_64 1:1.21.6-1.codeit.el7 will be updated
    —> Package nginx.x86_64 1:1.23.0-1.codeit.el7 will be an update
    —> Processing Dependency: libbrotli >= 1.0.9 for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    —> Processing Dependency: openssl-quic-libs >= 1.1.1 for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    —> Processing Dependency: libcrypto.so.81.1.1(OPENSSL_1_1_0)(64bit) for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    —> Processing Dependency: libssl.so.81.1.1(OPENSSL_1_1_0)(64bit) for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    —> Processing Dependency: libssl.so.81.1.1(OPENSSL_1_1_1)(64bit) for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    —> Processing Dependency: libcrypto.so.81.1.1()(64bit) for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    —> Processing Dependency: libssl.so.81.1.1()(64bit) for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    —> Running transaction check
    —> Package nginx.x86_64 1:1.23.0-1.codeit.el7 will be an update
    —> Processing Dependency: libbrotli >= 1.0.9 for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    —> Package openssl-quic-libs.x86_64 0:1.1.1p-1.codeit.el7 will be installed
    —> Finished Dependency Resolution
    Error: Package: 1:nginx-1.23.0-1.codeit.el7.x86_64 (CodeITmainline)
    Requires: libbrotli >= 1.0.9
    You could try using —skip-broken to work around the problem
    You could try running: rpm -Va —nofiles —nodigest

    when i check with this command : yum install brotli
    it’s show this information:
    Package brotli-1.0.7-5.el7.x86_64 already installed and latest version
    Nothing to do

    please help.

    Thanks.

Добавить комментарий

Ваш адрес email не будет опубликован.