NGINX 1.13.7-1 mainline с OpenSSL 1.1.0g и ngx_brotli для Red Hat Enterprise Linux и CentOS

В репозиторий добавлен NGINX 1.13.7-1 mainline-версии, собранный статически с OpenSSL 1.1.0g и «ngx cache purge«.

Ссылки:

Или же воспользуйтесь нашим репозиторием.

Apache httpd 2.4.29, собранный с OpenSSL 1.1.0g, ALPN и поддержкой http2 для Red Hat Enterprise Linux и CentOS

В репозиторий добавлен Apache httpd 2.4.29 с поддержкой http2 для Red Hat Enterprise Linux и CentOS. Mod_ssl собран статически с OpenSSL 1.1.0g. Ссылки:

Да, мы перешли на сборку Apache httpd c OpenSSL 1.1.0.

Заметим, что модуль Http2 Apache httpd с версии 2.4.27 не поддерживает prefork mpm. Ранее, в версии 2.4.26, мы наблюдали крахи с prefork и решили не выкладывать наши билды из-за них.
Если вам нужен модуль mod_http2, отключите prefork mpm, включите worker mpm в /etc/httpd/conf.modules.d/00-mpm.conf

Это действите уже сделано в файле, который мы поставляем в пакете. Если вы обновляете вашу инсталляцию, обновите файл.

Для работы с SELinux установите следующий boolean:

setsebool -P httpd_execmem=1

Для инсталляции проще воспользоваться нашим репозиторием. Обращаю ваше внимание на тот факт, что в зависимостях пакета присутствуют apr-util 1.5.0+ и libnghttp, которые я бы рекомендовал взять из репозитория EPEL. Таким образом, для использования Apache HTTPd проще всего подключить репозиторий EPEL:

yum install -y epel-release