NGINX 1.17.0 mainline с OpenSSL 1.1.1b TLS 1.3 Final (RFC 8446) и brotli для Red Hat Enterprise Linux и CentOS

В репозиторий добавлены NGINX 1.17.0 mainline версий, собранные статически с OpenSSL 1.1.1b, ngx cache purge и ngx http geoip2 module.
Работает сжатие brotli и поддержка TLS 1.3 final, которая поставляется в версии Google Chrome 70.

для включения TLS 1.3 надо указать:

ssl_protocols TLSv1 TLSv1.1 TLSv1.2 TLSv1.3;

Ссылки:

Или же воспользуйтесь нашим репо

NGINX 1.17.0 mainline с OpenSSL 1.1.1b TLS 1.3 Final (RFC 8446) и brotli для Red Hat Enterprise Linux и CentOS: 3 комментария

  1. This package has a dependency on libbrotli-1.0.6-1.codeit.el7.x86_64
    This conflicts with brotli-1.0.7-5.el7.x86_64 from EPEL
    The later package provides not only newer libraries, but the brotli command line tool.

    I’d be okay if the libbrotli package you provide gave the command line tool also, but as is I have a choice between ngnix with brotli, or the command tool when using repos.

    I got around this by compiling brotli from source into /usr/local so both libraries could exist on my system.

    Could you revise the dependency to accept the newer libraries from EPEL when that package is installed?

Добавить комментарий для Rick Gutzmer Отменить ответ

Ваш e-mail не будет опубликован. Обязательные поля помечены *