NGINX 1.13.8-1 mainline с OpenSSL 1.1.1-dev draft 18 branch и ngx_brotli для Red Hat Enterprise Linux и CentOS

В репозиторий добавлен NGINX 1.13.8-1 mainline-версии, собранный статически с OpenSSL 1.1.1-dev draft 18 branch и «ngx cache purge«.

Для тестирования TLSv1.3 необходимо добавить в вашем конфиге примерно следующее:

server {
...
ssl_protocols TLSv1 TLSv1.1 TLSv1.2 TLSv1.3;
ssl_ciphers TLS13-CHACHA20-POLY1305-SHA256:TLS13-AES-128-GCM-SHA256:TLS13-AES-256-GCM-SHA384:ECDHE:!COMPLEMENTOFDEFAULT;
ssl_ecdh_curve secp384r1;
...
}

Ссылки:

Или же воспользуйтесь нашим репозиторием.

NGINX 1.13.8-1 mainline с OpenSSL 1.1.1-dev draft 18 branch и ngx_brotli для Red Hat Enterprise Linux и CentOS: 4 комментария

  1. Hi! We’re loving the work you do and have been happily using the package on CentOS6.

    Seeing this error on 7 though:

    —> Processing Dependency: libbrotli = 1:1.0.3 for package: 1:nginx-1.13.12-1.el7.codeit.x86_64
    —> Finished Dependency Resolution
    Error: Package: 1:nginx-1.13.12-1.el7.codeit.x86_64 (CodeITmainline)
    Requires: libbrotli = 1:1.0.3
    Available: libbrotli-1.0.20160607.git.3f46e28-1.el7.codeit.x86_64 (CodeITmainline)
    libbrotli = 1.0.20160607.git.3f46e28-1.el7.codeit
    Available: libbrotli-1.0.20160726.git.77a0db1-1.el7.codeit.x86_64 (CodeITmainline)
    libbrotli = 1.0.20160726.git.77a0db1-1.el7.codeit

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *