NGINX 1.23.0 mainline with Brotli, TLS 1.3, OpenSSL 1.1.1p, HTTP/2 for Red Hat Enterprise Linux, CentOS, Rocky, Oracle, Alma Linux EL7/EL8/EL9

NGINX 1.23.0 mainline added to EL7, EL8, EL9 repositories. brotli compression module from Google, http2, ngx cache purge и ngx http geoip2 modules added or built-in. OpenSSL built dynamically using OpenSSL+QUIC 1.1.1p.

TLS 1.3 final works with Google Chrome 70+ and Mozilla Firefox 63+.

RHEL 8-9 / Alma Linux 8-9 / Rocky Linux 8-9 / CentOS 8-9 / Other EL8/EL9 repos are modular now.  To install nginx mainline, you need to enable the appropriate stream:

dnf module enable -y nginx:codeit-mainline

We build OpenSSL+QUIC 1.1.1 separately since v1.21.6, installing it separately to /lib64 with .so.81.1.1 suffix to ensure it won’t interfere with your system libraries.

5 thoughts on “NGINX 1.23.0 mainline with Brotli, TLS 1.3, OpenSSL 1.1.1p, HTTP/2 for Red Hat Enterprise Linux, CentOS, Rocky, Oracle, Alma Linux EL7/EL8/EL9”

  1. Hi,

    when i run command yum update, this error appear:

    Resolving Dependencies
    –> Running transaction check
    —> Package gd-last.x86_64 0:2.3.3-2.el7.remi will be obsoleted
    —> Package gd3php.x86_64 0:2.3.3-4.el7.remi will be updated
    —> Package gd3php.x86_64 0:2.3.3-7.el7.remi will be obsoleting
    —> Package nginx.x86_64 1:1.21.6-1.codeit.el7 will be updated
    —> Package nginx.x86_64 1:1.23.0-1.codeit.el7 will be an update
    –> Processing Dependency: libbrotli >= 1.0.9 for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    –> Processing Dependency: openssl-quic-libs >= 1.1.1 for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    –> Processing Dependency: libcrypto.so.81.1.1(OPENSSL_1_1_0)(64bit) for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    –> Processing Dependency: libssl.so.81.1.1(OPENSSL_1_1_0)(64bit) for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    –> Processing Dependency: libssl.so.81.1.1(OPENSSL_1_1_1)(64bit) for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    –> Processing Dependency: libcrypto.so.81.1.1()(64bit) for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    –> Processing Dependency: libssl.so.81.1.1()(64bit) for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    –> Running transaction check
    —> Package nginx.x86_64 1:1.23.0-1.codeit.el7 will be an update
    –> Processing Dependency: libbrotli >= 1.0.9 for package: 1:nginx-1.23.0-1.codeit.el7.x86_64
    —> Package openssl-quic-libs.x86_64 0:1.1.1p-1.codeit.el7 will be installed
    –> Finished Dependency Resolution
    Error: Package: 1:nginx-1.23.0-1.codeit.el7.x86_64 (CodeITmainline)
    Requires: libbrotli >= 1.0.9
    You could try using –skip-broken to work around the problem
    You could try running: rpm -Va –nofiles –nodigest

    when i check with this command : yum install brotli
    it’s show this information:
    Package brotli-1.0.7-5.el7.x86_64 already installed and latest version
    Nothing to do

    please help.

    Thanks.

    1. Hello,
      Please run
      yum install -y https://repo.codeit.guru/codeit-repo-release.el7.rpm
      yum-config-manager --enable CodeIT-mainline --save

      I think that you may not have stable repo enabled.
      Please also remove old codeit.repo conf file.
      And try again.

    1. Hi Sam,
      Our packages do not use openssl111-libs package anymore.
      New dependency is OpenSSL+QUIC fork: openssl-quic-libs, the latest version is openssl-quic-libs-1.1.1q.
      You can safely delete openssl111*.

Leave a Reply to Sam Cancel reply

Your email address will not be published.